MetaMask, Phantom and Other Browser Wallets Patch Security Vulnerability

MetaMask, Phantom and Other Browser Wallets Patch Security Vulnerability


Steve Walbroehl, Halborn’s co-founder, told CoinDesk, “Just given the fact that this is something that has been around for so long, you don’t know who possibly could have gotten [exploited]. Maybe you clicked on a bad phishing email and they have access to your machine. Maybe somebody took it before even though you’ve now upgraded. I just think out of an abundance of caution, given the criticality, it’s better to just change it.”

Continue reading


 

Join the conversation!

Please share your thoughts about this article below. We value your opinions, and would love to see you add to the discussion!

Thanks for sharing!
Send this to a friend